SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

No geometry in exported STEP file (by yugami)
I followed the bracket tutorial and exported it to a STEP file then tried to import it into SALOME (7.4) and FreeCad (0.14). SALOME reports there is no geometrical data and FreeCad just shows nothing.

This is on Windows 8.1

STL meshes work for SALOME and FreeCAD but cause issues with Elmer (crash)

This is really great software but I would love to be able to import the geometry into SALOME to be able to generate and tweak Meshes and use Elmer to do basic testing.
Sat Jan 31 2015, 22:54:32
(no subject) (by yugami)
I tried an online viewer ( http://www.3dvieweronline.com/index.html )

and IDA-STEPs free viewer and get similar results. no geometry imported.
Sun Feb 1 2015, 13:35:41
Partially solved (by hand) (by yugami)
I started comparing the export from solvespace to a downloaded sample STEP file

The downloaded file was from

http://www.steptools.com/support/stdev_docs/stpfiles/ap203/

block.stp

I made a simple block in solvespace and exported it. Then started comparing differences. Besides the obvious differences in how geometry is handled it appears the issue (partially) lies in some of the support type data. I've attached the manually edited file which imports into FreeCad with some issues but its further along than it was. The issues is that it actually imports 5 things (all of them the block but possible different views?) The downloaded file only imports 1 thing

The data I added was

#175=SHAPE_DEFINITION_REPRESENTATION(#176,#169);
#176=PRODUCT_DEFINITION_SHAPE('Version','Test Part',#177);
#179=PRODUCT('1','Product','Test Part',(#178));
#177=PRODUCT_DEFINITION('Version','Test Part',#187,#178);
#178=DESIGN_CONTEXT('3D Mechanical Parts',#181,'design');
#187=PRODUCT_DEFINITION_FORMATION_WITH_SPECIFIED_SOURCE('Version',
'Test Part',#179,.MADE.);
#180=MECHANICAL_CONTEXT('3D Mechanical Parts',#181,'mechanical');
#181=APPLICATION_CONTEXT(
'configuration controlled 3d designs of mechanical parts and assemblies
');

Its been about 12 years since I was a programmer so hopefully this helps someone on the STEP export.
Mon Feb 2 2015, 10:14:37, download attachment block-solvespace.stp
One small change (by yugami)
#179=PRODUCT('1','Product','Test Part',(#180));

Wrong reference is 179.

Salome still has some issues. It imports OK as Geometry but the Mesher doesn't recognize it as 3D (Generate Mesh only shows 2d Solutions available)
Mon Feb 2 2015, 11:04:25
(no subject) (by yugami)
It appears that the issues in both Salome and Freecad are that the geometry is seen as a distinct group of faces and not one solid. In freecad the list of items are each of the faces of the cube that can be deleted one by one.
Mon Feb 2 2015, 12:09:26
(no subject) (by Jonathan Westhues)
Everyone implements a different subset of STEP. I'd guess that FreeCAD and SALOME use a translator derived from the same source, since they're both OpenCASCADE-derived, so it makes sense that both or neither work.

If anyone wants to reverse-engineer the format they're expecting, and prepare a change to generate that (without breaking existing translators; I usually test against Rhino), then I'm glad to integrate on gitorious.
Mon Feb 2 2015, 14:23:43
(no subject) (by yugami)
The only difference between the block sample I downloaded and the export from solvespace I see is that you use BOUNDED_SURFACE instead of PLANE when defining ADVANCED_FACE.

Elmer will now open the STEP but will crash trying to generate the Mesh, I'm assuming due to the same reason. Not seeing an actual solid for some reason.
Mon Feb 2 2015, 15:57:53
(no subject) (by yugami)
This basically just prints what I had to add to files to get the surfaces to import. It would be interesting to have the ability to set the header information (Product name, part name, designer, etc) but that's unimportant.

I still have to combine them to a valid solid for some reason but its a step closer than we were.

I am not a STEP format expert and there appears to be very little down to earth information on the format. I don't believe its a flaw in OpenCascade because Elmer does not detect 3D geometry when importing either the raw STEP from SolveSpace or with my updated header. LISA-FET has issues as well with the geometry.

However with a few steps I'm now able to conduct FEM on SolveSpace constructed entities which is the end goal.
Sat Feb 7 2015, 11:22:27, download attachment exportstep.cpp
Freecad macro (by yugami)
For now my work flow is running my solvespace designs through FreeCAD to make a solid.

I created this little macro to automate the process. Once you import the file into FreeCAD simply select the faces that it shows and run the Macro. The Macro combines all the objects into a solid and removes the imported objects. You can then export this file for use in a number of different Opensource tools like Elmer-FEM

Ultimately I would like to add another export option to solvespace to bypass this but I'm still figuring out the format differences to make it happen.

I've attached the macro here in case it is useful to anyone else.
Tue Feb 10 2015, 10:13:07, download attachment meld.FCMacro
Exporting Step from Solvespace (by Tim)
Yugami and Jonathan

I have also had this problem (see my post yesterday 9.10.2015).

I sent this problem to the forum for Mecway (the FEA program I use to import with). The moderator's response is given below:

**********************************************************
I tried opening both STEP files in various programs with these results:

tute01wfrm.step:
Mecway - no. Error message
FreeCAD - no. Appears blank
ShareCAD Viewer online (http://beta.sharecad.org/viewer) - no. Appears blank
Strand7 - no. It says it has no surfaces
A360 Viewer - yes. It shows a wireframe shape

tute01surf.step:
Mecway - no. Error message
FreeCAD - no. Appears blank
ShareCAD Viewer online (http://beta.sharecad.org/viewer) - no. Appears blank
Strand7 - yes
A360 Viewer - yes

So I wouldn't expect to get anywhere with the wireframe one because you won't be able to generate a 3D mesh from it in probably any software.



I suspect the surface file might be a set of distinct surfaces instead of a proper solid part. Looking closely at the A360 image you can see little gaps around the edges of the holes which don't appear on another STEP file I tried. Perhaps you would need some other software to join the edges together, if this is really the problem.
*************************************************************
Fri Oct 9 2015, 20:03:23
(no subject) (by Paul)
Yugami, after running the macro, does that saved file load correctly in the tools mentioned in this thread? Can you upload a simple example of a broken SolveSpace export along with the fixed version in the same format? That may be helpful to determine what the issue is. Or it may have a lot of extra content added beyond what's needed.
Sat Oct 10 2015, 19:49:18
(no subject) (by yugami)
I don't think Johnathan ever released a new executable the fix is available in the source of your compile yourself
Sun Oct 11 2015, 16:36:26
(no subject) (by whitequark)
You can use my binary builds as well, e.g. https://github.com/whitequark/...eleases/tag/nightly.2015-09-19
Wed Oct 14 2015, 22:29:25
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.