SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

Exported circle as DXF is actually a 16-sided polygon (by Dave)
I'm trying to export a 2D section of what is basically a piece of thin plywood with a hole cut in the middle (about 40mm diameter).

The hole cut in the middle is actually a different SLVS file that I have imported as a "difference". The imported SLVS, if opened in its own Solvespace instance, clearly has more than 16 lines making up the circle.

When I export the section to DXF, I find that the DXF has a 16-sided polygon where the circle should be. I decreased the chord tolerance hoping that would put more sides on the polygon but nothing changed.

Is there a way to export an actual circle to DXF?

Many thanks!
Wed Sep 23 2020, 11:33:26
(no subject) (by Paul)
What chord tolerance did you use? and which one? how big is your plywood?

The one labeled "chord tolerance (in percents)" is used for visuals - on screen. The other one labeled "export chord tolerance (in mm) is the one that's used for exporting to other file formats. Also, the one in percent is used to compute one in mm but it's based on the overall size of the sketch. For example, at the default setting of 0.1 percent a 2 meter (2000 mm) board will have a chord tolerance of 2mm.

Just to check I make a 2m by 1m rectangle with a 40mm diameter hole. It was 16 sided on the display (which is the new minimum, it used to be 8 sided). I had to lower the CT to 0.02 percent before the number of edges increased CT = 0.4mm at that point. Goint to 0.01 percent looks better at 0.2mm.

Regardless of percent setting you'll want an export chord tolerance of 0.2mm or less. Don't worry about the max piecewise segments, it's 64 per quadrant of the circle by default.

I hope this is just a misunderstanding of the CT settings, and not an actual bug ;-)
Wed Sep 23 2020, 14:57:26
(no subject) (by Andrew)
With Solvespace 2.3,,export 2d view produced circles when i imported a circle in 2d to a 2d square, imported as a 2d circle and extruded to punch a hole in an extruded square, or as an extruded rod to punch the hole. I used LibreCAD to check the exported dxf.

Which version of Solvespace were you using, and it might be useful if you zipped up the files as an attachment, so that an example of the problem is available.
Wed Sep 23 2020, 15:05:05
(no subject) (by Dave)
Thanks for the replies. I have just done another test with the latest version of solvespace in Github (master) and the circle now comes out with more segments and is thus more akin to a circle. My old version may well have been the problem. I attach the output I get using the latest solvespace.

My export chord tolerance is 0.02mm and export max piecewise linear elements is 64.

Cheers.
Mon Sep 28 2020, 06:17:48, download attachment test.dxf
Problem rediscovered (by Dave)
I am designing a 4 legged tripod.

I incorporate my 4 legged tripod in a "main.slvs" file which aims to produce an attachment for one of the tripod legs which I would like to 3D print. When I export the stl from "main.slvs" I end up with a 16 sided cyclindrical cut out that looks terrible on the 3D printer.

Please see attached files - I believe you will finally see the same problem as me! Thanks for your attention.
Fri Oct 2 2020, 18:13:38, download attachment Problem.zip
(no subject) (by Andrew)
I managed to fix your problem by going into the configuration for the tripod sketch, and changing the export chord tolerance to 0.001. You can play with the value to get the resolution you want, just remember to save the file after changes to recreate the export model that main will pull in.
Sat Oct 3 2020, 12:31:26
(no subject) (by Dave)
I didn't know that the chord tolerance on the child model had to be increased and then re-saved. That is useful to know.

I tried doing the steps you suggested but I still find that the exported model ends up like the one I attach - with a polygon instead of a circle.

For clarity, I have Solvespace 3.0-0a061b6f which I built from github a few weeks ago.

I've attached an image of my settings in case I'm going mad. Thanks a lot.
Sun Oct 4 2020, 15:42:53, download attachment untitled.stl
(no subject) (by Dave)
And the settings attached to this message:
Sun Oct 4 2020, 15:43:26, download attachment a.png
(no subject) (by Andrew)
Attached are the renamed and fixed files. I am using version 3.0-6b7f146 from the AUR.
Hope this helps.
Sun Oct 4 2020, 17:56:33, download attachment problem_fixed.zip
(no subject) (by Tom)
Yeah, I've seen this too. Looks like the surfaces/triangles get imported directly from the child, and not regenerated with the parent settings. Easy fix but confusing.
Mon Oct 5 2020, 00:19:03
(no subject) (by Dave)
Thank you for the corrected files. If I use my "main.slvs", I can immediately see on opening "main.slvs" that the imported file is much higher resolution than before. If I use my own "main.slvs" and edit it manually to change the imported file names to "Tripod-fixed.slvs" I see that my own "main.slvs" displays the correct behaviour.

I have just done a checkout of the very latest Solvespace but I cannot for the life of me manage to get my own "Tripod.slvs" to save with the high resolution information. I have set/unset/set the export chord tolerance to 0.001 and saved and resaved.
No resolution change in "main.slvs".
I even changed the length of the tripod legs and saved that.
No resolution change in "main.slvs".
I saved my "Tripod.slvs" as a completely different file name and edited "main.slvs" in a text editor to import that, but still no resolution change.

What is the "AUR"?

What I am literally doing is opening "Tripod.slvs" in Solvespace, checking to make sure that the export chord tolerance is 0.001, and then doing File->Save. I then open "main.slvs" and go Edit->Regenerate all. Do I need to do anything else than the "Save"?

I did a diff between "Tripod.slvs" and "Tripod-fixed.slvs" and noticed that there are an awful lot of lines starting with "Triangle" that are different in case that means anything.

Sorry my setup is misbehaving. I thought I had a fairly good working setup of the latest build but I'm at a loss to explain why we are seeing a difference in behaviour.

Thanks once again.
Mon Oct 5 2020, 12:32:06
(no subject) (by Tom)
Did you regenerate (in Tripod.slvs) after changing the chord tolerance but before saving?
Mon Oct 5 2020, 12:37:06
(no subject) (by Dave)
Tom,

Yes I did.

But I have just now worked out the problem. I was changing the "export chord tolerance" but that has no effect on parent models.

In fact, I had to change the "chord tolerance" and that fixed my issue.

Andrew, in a previous message when you first mentioned 0.001 did you mean to say "chord tolerance" instead of "export chord tolerance"?

Cheers all!
Mon Oct 5 2020, 12:40:33
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.