SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

Architectural units: Feet' Inches" ? (by DavidOertl)
I do not find an option for "architectural units" such as (imperial) architects use; e.g. feet inches 16ths-of-an-inch.

As an, enterprising, imperialist, I will design my housing project in inch units, but interpret them as feet when plotting.

That is to say, my 9.34-inch-tall design will be cutout 9.34-feet-tall when constructed.

I think that will work...
Tue Dec 31 2019, 16:01:03
(no subject) (by Andrew)
The View menu allows you to dimension in inch units, while the configuration options allow you to scale the output. Will a combination of these meet your requirements.
Tue Dec 31 2019, 19:06:00
(no subject) (by DavidOertl)
Sounds likely, but I had difficulty finding the output scale setting in the configuration window.

I would have sworn it wasn't there the several times I looked for it before, but just now--after the crash--I made the top-most window the active one on the Home window and clicked /config at the bottom, and there it was. (Any chance it's context-sensitive?)

Anyway, after I re-started SolveSpace and re-loaded the auto-saved project, I found the "export scale factor" set to '1:1=mm'.

Too, I found that despite my threat to use inches, View->Dimensions-in-Millimeters was set.

Nevertheless, the dimensions of my project were changed by the crash/re-load.

Where I had a 60x24mm rectangle base before, it now reports to be 1523.32x605.54mm. Similarly a 20mm tall edge is now reporting as 508mm. (Now, although 508/20==25.4, I was not "exporting" but "saving" and "autosaving" so I wouldn't expect an export-scale-factor to be in play.)

I had launched into SS intending to learn as I went along. However, the crash appears to have ruined my first project, and left me concerned.

Help->About reports "v2.3~".
Tue Dec 31 2019, 19:46:44, download attachment Home_RooflineChange_HomeAddition.slvs
(no subject) (by DavidOertl)
I'm trying to use it to change the roof pitch on a house, and find the lines of intersection for a new roof on an addition.

As I'm not going to "machine" the resultant model, it doesn't matter that what I'll call "1 foot" is really just 1 inch, "1 inch over" on my model will correspond to "1 foot over in the real world" (or 1 meter, or 1 furlong, depending on my fancy).

I tried to disable the autosave by setting it to '0' which threw an error (apparently "autosave" is required), so I set it for 28,800. I don't mistrust autosave, but just hate the thought of opening an "autosaved" version of a bad file will, shortly thereafter, also autosave, thus overwriting what may still have been a good original on-disk.
Tue Dec 31 2019, 20:10:48
(no subject) (by Andrew)
With respect to dimensions, Solvespace works internally in mm, and converts to and from inches if required. It does not change actual dimensions when switching between mm and inches. It looks like the autosave had not kept the inches setting. switching back to inches would have restored the expected numbers.

Note, with respect to autosave, it is an option to load it, and that does not have any impact on the previous version in the original file name. It is always safe to use an autosave, because if it bad, you can reload the original, or close solvespace without saving over the original.
Wed Jan 1 2020, 07:49:49
(no subject) (by Marcus)
Being able to display the dimensions in feet + inches (e.g. 5' 4") would be useful for export 2d views. I recently used Solvespace to draw a floorplan for a building permit, for which it worked really well, but the city required the PDFs units in feet+inches and it's going to be a pain to label them manually.
Wed May 20 2020, 00:25:59
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.