SOLVESPACE -- parametric 2d/3d CAD

(you are viewing a thread; or go back to list of threads)

Fixing dimensions entered as meters (by Steve)
Hi All,

This is my first SolveSpace drawing, and I've realised I've been typing in my measurements in m rather than mm -- this bin (for example) should be 1.2m across, but I've specified mm and typed 1.2.

Is there an easy way to fix this? I literally want to multiply every constraint by 1,000.

Fri Dec 20 2019, 16:18:28
(no subject) (by Andrew)
If you go into configuration, you can change the scale factor for export. There is also a paste transformed operation, which would speed up re-scaling the drawings.
Fri Dec 20 2019, 17:39:54
(no subject) (by Steve)
Thanks for the quick reply.

I was able to Ctrl-A (select all), Ctrl-X (cut), Edit > Paste Transformed, change the scale to 1000 (in the Property Browser), then paste. Proportions look identical -- so that fixed it. Thanks again.

Alas, I can't find a configuration option on the menus. I'm using v2.3~7c1ca460 on Windows. Maybe that's a bug; dunno.

Happy Christmas, all.
Sun Dec 22 2019, 12:11:15
(no subject) (by Andrew)
The configuration settings are accessed through the properties window.. When at the top level, list of groups visible, there are the links for line styles, views and configuration in a line at the bottom of the list.
Sun Dec 22 2019, 13:38:12
Thanks (by Steve)
Great; found it!
Mon Dec 23 2019, 04:32:20
Post a reply to this comment:
Your Name:
Your Email:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.