SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

translate -> rotate -> extrude no workplane (by Mike O)
Folks,

Not sure if I'm doing something silly, or there is really a problem. Seems like I before I had no issues rotating and then extruding, but in this model it keeps complaining about lack of workplane selection prior to extrusion. Running the latest code from the Github.
Wed Jun 5 2019, 02:16:04, download attachment top.slvs
(no subject) (by Andrew)
There is no workplane selected, and to do so, select a workplane, dashed blue outline, and then click to sketch in workplane in sketch menu.
Wed Jun 5 2019, 05:17:50
(no subject) (by Mike O)
Well, the intent was to make a bunch of holes in the sketch. I drew one circle, translated it to make 5 of the same, then rotated to make 5 groups, and then wanted to extrude the difference... I believe I did something similar before and it worked, but this time I can't extrude post-rotate.
Wed Jun 5 2019, 10:12:59
(no subject) (by Andrew)
That error message means that somehow you are no longer have a workplane selected. Open the sketch menu and you will see that anywhere in 3d is selected selected. To be able to extrude, select the workplane that surrounds your plate, and then use the sketch menu to select 'In Workplane' and then you can extrude normal to that plane..
Wed Jun 5 2019, 10:28:14
(no subject) (by Paul)
The point you chose to rotate around seems to have something to do with it. I deleted the rotate group and created a new one around a new point. The resulting group could be extruded (as can your translate repeating group) to create holes.
Wed Jun 5 2019, 10:29:25
(no subject) (by Mike O)
Paul,

Thanks! I suspected a trivial error on my part, and fresh eyes always help.
Wed Jun 5 2019, 10:44:31
(no subject) (by Mike O)
Well, I played a bit more with it, and still can't get this to work. Say from an empty sketch :

1) Draw a circle
2) Translate (makes 3 circles by default)
3) Rotate around Z normal and center
4) Extrude... no workplane :(

If you extrude after step 2, it works - three cylinders are produced. But if you rotate those, extrusion is lost. I also tried rotating around a random point and Z normal, still the same issue.
Fri Jun 7 2019, 11:45:33, download attachment untitled.slvs
(no subject) (by Andrew)
I can do what you suggest, and the extrude works every times. In the sample sketch you attached however, you have somehow switched to sketch 'Anywhere in 3D', and and you need to be in sketch 'In Workplane' for extrude to work. Select the xy workplane and then in the 'Sketch' menu toggle 'In Workplane' on and then you can extrude the cylinders. Alternatively select the workplane and type '2'.

The first two entries of the 'Sketch' menu are radio buttons that allow switching between drawing in 3d, and drawing on a workplane.

There are many keyboard shortcuts in Solvespace, including '3' to switch to sketch anywhere in 3d.
Fri Jun 7 2019, 14:19:34
(no subject) (by Mike O)
Andrew,

Your suggestion worked, though the flow is somewhat weird. I tried the process in yet another new sketch, on a different computer and with older SS version, and after rotation I do have "In Workplane" selected but extrusion isn't working. I then selected XY plane and clicked on "In Workplace" again, and then extrusion does work.
Fri Jun 7 2019, 17:52:23
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.