SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

How to do a cone in a solid (by patrovite)
Hi all,

First I would like to thanks all the developpers and contributors of solvespace. You did a great job.

On a cube I want to do a hole in order to put FHC screw (screw with a conic head).

Here is what I did :
- On a solid I "drilled" the hole of the screw
- I selected the axis of the screw and create a workspace
- I draw the shape of the cone
- I lathe the cone and in the parameters I selected "difference"
- The program crashed and closed

I tried several times with the same result.

May be I don't use the right method.

Any tips or advice?

I use Solvespace 3.0 - 6637 under XUbuntu (compiled from the git source).
Wed May 3 2017, 08:54:46
(no subject) (by whitequark)
It shouldn't crash. Can you please file an issue at https://github.com/solvespace/solvespace/issues, make the model as you describe above (without the step that crashes it), and attach it?
Wed May 3 2017, 13:49:49
(no subject) (by Azial)
If you combine the hole and the chamfer in one sketch (the hole is a rect starting from the center), it definitely works, see the attached file.
Wed May 3 2017, 15:21:47, download attachment Cube with hole.slvs
(no subject) (by patrovite)
Hi Azial,

I tried with your file and it works. If I try to create the same design from scratch, it fails. Do you use the same version as me?
If I launch Solvespave from the console, when the program crash it produce these messages :

File /home/pierre/src/solvespace/src/dsc.h, line 334, function FindById:
Assertion 'Cannot find handle' failed: ((t != NULL) == false).
Backtrace:
0: solvespace(_ZN10SolveSpace14assert_failureEPKcjS1_S1_S1_+0x58) [0x483be8]
1: solvespace(_ZN10SolveSpace6Vector4FromENS_6hParamES1_S1_+0x77) [0x5671d7]
2: solvespace(_ZN10SolveSpace5Group18ExtrusionGetVectorEv+0x39) [0x4e6489]
3: solvespace(_ZN10SolveSpace10TextWindow23ScreenChangeGroupOptionEij+0x132) [0x551b22]

...

I linked my file to this message. You only need to lathe the shape to generate the crash.

I'll also create an issue on github.
Wed May 3 2017, 17:20:35, download attachment test3.slvs
(no subject) (by patrovite)
The last version compiled from github solve my problem.
The only addition to my procedure is to select "force NURBS surfaces to triangle mesh" and then the result is ok.

Thanks
Thu May 4 2017, 09:01:57
(no subject) (by patrovite)
Additional question : What's the easiest way to create the worplane to draw the shape to lathe?

Currently I use a construction line to do this. In some case it's not very easy.
Thu May 4 2017, 09:06:30
(no subject) (by whitequark)
If the workplane you want is parallel to XY/YZ/XZ plane, then you can select the origin of the workplane, orient the view so that it is approximately parallel to your desired workplane, and create it (either via Sketch -> Workplane or New Group -> Sketch In New Workplane).
Fri May 5 2017, 03:49:24
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.