SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

How to model a pipe elbow? (by Gabriele Santilli)
How would I go about modeling a pipe elbow like this? http://ec-i21.geccdn.net/site/images/n-picgroup/88906.jpg
Sat Dec 31 2016, 20:17:07
(no subject) (by whitequark)
Hi Gabriele,

See the attached file.
Sun Jan 1 2017, 02:13:50, download attachment pipe-elbow.slvs
Thanks! (by Gabriele Santilli)
Thank you,

when I tried that before posting here I got problems like you can see in the attached picture, so I figured I was doing something wrong.
Mon Jan 2 2017, 16:10:09, download attachment UnionFail.png
(no subject) (by whitequark)
The kind of problems where the boolean operation fails can be fixed by checking the "Force NURBS surfaces to triangle mesh" option.
Mon Jan 2 2017, 19:36:07
Installation error (by George)
Hello,
I am stuck trying to install Solvespace on Ubuntu 0.16. I did the following:
Downloaded Solvespace from Github, unpacked it, created the directory "build", and from within this directory I ran cmake ..
I ve pasted the output below and hope that someone will be out there to explain the errors or at least give me a clue where to look.
I expected the errors at libdxfrw. I downloaded this lib from Github and unpacked it to the empty extlib/libdxfrw/ directory that was created during the unpacking of the Solvespace tar file. Probably can't combine software this way (lol).

[email protected]:~/Downloads/Solvespace/src/solvespace-2.3/build$ sudo cmake ..
[sudo] password for george:
CMake Error at cmake/GetGitCommitHash.cmake:8 (file):
file failed to open for reading (No such file or directory):

/home/george/Downloads/Solvespace/src/solvespace-2.3/.git/HEAD
Call Stack (most recent call first):
cmake/GetGitCommitHash.cmake:35 (get_git_commit_hash)
CMakeLists.txt:23 (include)


-- The C compiler identification is GNU 5.4.0
-- The CXX compiler identification is GNU 5.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so
-- Using in-tree libdxfrw
CMake Error at CMakeLists.txt:99 (add_subdirectory):
The source directory

/home/george/Downloads/Solvespace/src/solvespace-2.3/extlib/libdxfrw

does not contain a CMakeLists.txt file.


-- Found SPACEWARE: /usr/lib/libspnav.so
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1")
-- Checking for module 'zlib'
-- Found zlib, version 1.2.8
-- Checking for module 'libpng'
-- Found libpng, version 1.2.54
-- Checking for module 'fontconfig'
-- Found fontconfig, version 2.11.94
-- Checking for module 'json-c'
-- Found json-c, version 0.11.99
-- Checking for module 'glew'
-- Found glew, version 1.13.0
-- Checking for module 'freetype2'
-- Found freetype2, version 18.1.12
-- Checking for modules 'gtkmm-2.4;pangomm-1.4;x11'
-- Found gtkmm-2.4, version 2.24.4
-- Found pangomm-1.4, version 2.38.1
-- Found x11, version 1.6.3
-- Configuring incomplete, errors occurred!
See also "/home/george/Downloads/Solvespace/src/solvespace-2.3/build/CMakeFiles/CMakeOutput.log".
Wed Jan 25 2017, 12:44:47
(no subject) (by whitequark)
> Downloaded Solvespace from Github, unpacked it, created the directory "build", and from within this directory I ran cmake ..

There's the cause. Please use `git clone`, not the GitHub downloads. Unfortunately GitHub doesn't add all required files into the archive.
Sat Jan 28 2017, 14:44:27
How do you construct a pipe knee? (by jsilence)
Dear whitequark,

thanks for providing the pipe elbow.

I am new to Solvespace and CAD drawing and I am curious how I would construct this piece. Actually a simpler version would suffice for my needs, like a quarter of a torus.

Is there any small tutorial on how to build something like that?
Tue Jan 31 2017, 00:48:24
(no subject) (by whitequark)
Sure. Switch across the active groups in the file I've attached earlier and you'll see. In short, I first create a full torus and then cut away 3/4 of it.
Tue Jan 31 2017, 01:03:40
(no subject) (by jsilence)
Dear whitequark,

yes, I suspected that this is the way. I managed to produce a torus, but I am unsure how to cut away 3/4 of it.

Do I draw/extrude cubes? If so, how do I combine the two solids to cut away the unwanted part of the torus?
Tue Jan 31 2017, 07:21:29
(no subject) (by whitequark)
Please look at the file I have posted, you will easily see the way it is constructed.
Tue Jan 31 2017, 16:10:40
(no subject) (by ruevs)
pipe-elbow.slvs causes 2.2 and 2.3 to crash/close immediately upon opening it on Windows.

They do not crash on Link/Assemble.

2.0 does not crash - it just complains about unrecognized data and opens the file without one of the flanges.

2.1 does not crash and does not complain - it opens the file without one of the flanges.
Fri Mar 24 2017, 10:31:44
(no subject) (by ruevs)
Correction - 2.1. crashes just like 2.2 and 2.3
Fri Mar 24 2017, 10:35:58
(no subject) (by whitequark)
@ruevs, just tried it with wine and on a Windows 10 VM, no crash. This seems bizarre. Perhaps the file got corrupted?

Are you able to retrieve a backtrace for the crash? The .pdb file for solvespace.exe is available for download on https://github.com/solvespace/solvespace/releases, for 2.2 and later.
Sat Mar 25 2017, 08:17:09
(no subject) (by Andreas)
Crashes here too. How do I retrieve a backtrace?
Fri Mar 31 2017, 05:53:26
(no subject) (by whitequark)
Andreas, install Visual Studio 2013 or later, and set it as the "just-in-time" debugger, then run SolveSpace, and once it crashes and Visual Studio attaches, feed it the .pdb file from the link above.
Fri Mar 31 2017, 16:52:04
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.