SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

Building Solvespace for ARM/Raspberry Pi (by thetinker)
Has anyone ever built Solvespace on/for Raspberry Pi?
Is it possible?
I have trouble with some of the dependencies (gcc5+)
also I dont know how to setup the git extlib/libdxfrw
Fri Dec 9 2016, 21:04:33
(no subject) (by whitequark)
The submodule can be set up using:

$ git submodule update --init extlib/libdxfrw

As for gcc 5+, it looks like gcc 4.9 that ships with Raspbian is enough to pass the test suite, so you can disable the check (at CMakeLists.txt:60).

You will need to enable the desktop OpenGL driver using `sudo raspi-config` -> Advanced Options.

I've been able to build and run SolveSpace on Raspberry Pi 3, and it seems to work acceptably.
Sat Dec 10 2016, 01:49:40
extlib/libdxfrw (by thetinker)
I am unfamiliar with git used this way (Or any way for that matter , I am not a programmer)

If I run this command:
git submodule update --init extlib/libdxfrw
It says error pathspec extlib/libdxfrw did not match any files.

where should I cd to, to run this?

I have downloaded the libdxfrw.zip file but don't know where to put it,or if it needs to be unzipped etc ...
Sat Dec 10 2016, 09:36:50
(no subject) (by whitequark)
You need to run this from the solvespace git checkout.
Sat Dec 10 2016, 18:31:03
can't compile on Orange Pi Plus 2 (by watchdog_timer)
I'm trying to compile Solvespace on an ARM7 board similar to a Raspberry Pi 3, the Orange Pi Plus 2 running a version of Debian 8 called Armbian.

The version of Cmake in the respositories was 3.0.2, so I downloaded and compiled 3.1.0 to get it to meet requirements.

The version of gtkmm-3.0 in the repository is 3.14 instead of 3.16, so I modified the CMakeLists.txt file to accept version 3.14 instead.

Making that change allows it to build without error, but when I run 'make' the files I get the following error:

[ 94%] Building CXX object src/CMakeFiles/solvespace.dir/platform/gtkmain.cpp.o
/home/jim/solvespace/src/platform/gtkmain.cpp:21:26: fatal error: gtkmm/glarea.h: No such file or directory
#include <gtkmm/glarea.h>

Any suggestion on what I could do differently?
Sat Jan 21 2017, 17:43:12
(no subject) (by whitequark)
> Any suggestion on what I could do differently?

Install gtk and gtkmm 3.16. Using any earlier version of gtkmm is not supported anymore with SolveSpace 3 on Linux.

Use SolveSpace 2.
Sun Jan 22 2017, 05:00:32
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.