SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

Building on lubuntu 1610 (by Andrew Bromley)
The https://github.com/solvespace/solvespace version built OK on lubunto 1610, (installed in virtual box) but failed when run with:

glGetError() == 0x502 invalid operation
The program 'solvespace' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
(Details: serial 295 error_code 8 request_code 72 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)


compilations produce the following warnigs

/home/andrew/manual _install/solvespace/src/drawentity.cpp: In member function ‘void SolveSpace::Entity::ComputeInterpolatingSpline(SolveSpace::SBezierList*, bool) const’:
/home/andrew/manual _install/solvespace/src/drawentity.cpp:298:17: warning: this ‘if’ clause does not guard... [-Wmisleading-indentation]
if(i > 0) bm.A[i][i - 1] = eq.x;
^~
/home/andrew/manual _install/solvespace/src/drawentity.cpp:299:31: note: ...this statement, but the latter is misleadingly indented as if it is guarded by the ‘if’
bm.A[i][i] = eq.y;
Mon Nov 7 2016, 09:00:59
Addendum (by Andrew Bromley)
https://github.com/whitequark/solvespace.git

the above version builds and runs fine.
Mon Nov 7 2016, 09:27:45
(no subject) (by whitequark)
Are you using VirtualBox's 3D acceleration? If not, try enabling it.
Tue Nov 8 2016, 06:02:25
(no subject) (by Andrew Bromley)
Not enabling 2d acceleration, (it somehow slipped my setup of the machine), solved the problem.
By the way, both version were built on the same virtual machine without 3D acceleration, and one failed and the other worked.
Tue Nov 8 2016, 08:12:48
(no subject) (by whitequark)
In general VirtualBox's graphics is very flaky if one uses OpenGL. There are no less than three workarounds in SolveSpace's source code just so that VirtualBox could be used. I don't consider fixing it as a priority given that we support all major platforms natively.
Tue Nov 8 2016, 08:24:28
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.