SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

Obtaining slvs.dll (by Michael Parker)
Hi,

I'm trying to run the VB example using MS Visual Studio Express 2013 for Windows Desktop and it errors out with "unable to load dll 'slvs.dll'".

Is there a pre-built DLL file available to download? If not, are there any guidelines available on how to build it using Visual Studio Express?

Thanks,

Michael
Tue Apr 15 2014, 18:13:19
(no subject) (by Jonathan Westhues)
From an MSVC command shell (for example, after running vcvars32.bat), go to solvespace/exposed, and run nmake.

I believe that should work with any version of Visual Studio (or without Visual Studio, if you just download the Platform SDK). Let me know if you have any trouble.
Wed Apr 16 2014, 04:47:22
(no subject) (by Michael Parker)
Thanks for your reply - I tried running vcvars32.bat, then nmake in the \exposed directory, and got the following, which seems pretty strange, as if there were errors in the math.h file provided by Microsoft:


C:\>cd "\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin"

C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin>vcvars32.bat
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin>cd "\Program Files\SolveSpace\solvespace-rel2.0\solvespace\exposed"
C:\Program Files\SolveSpace\solvespace-rel2.0\solvespace\exposed>nmake

Microsoft (R) Program Maintenance Utility Version 12.00.21005.1
Copyright (C) Microsoft Corporation. All rights reserved.

util.cpp
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\INCLUDE\math.h(423) : error C2226: syntax error : unexpected type '_Ty'
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\INCLUDE\math.h(429) : error C2143: syntax error : missing ';' before '{'
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\INCLUDE\math.h(429) : error C2447: '{' : missing function header (old-style formal list?)
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\BIN\cl.EXE"' : return code '0x2'
Stop.

C:\Program Files\SolveSpace\solvespace-rel2.0\solvespace\exposed>

I'm running Windows 7 Professional, Service Pack 1, 64-bit, and have Visual Studio Express 2013 for Windows Desktop installed, v12.0.21005.1.

Best regards,

Michael
Fri Jul 25 2014, 16:01:08
(no subject) (by Jonathan Westhues)
Can you post those lines of math.h? I'm wondering if we're defining a macro that breaks something there.
Sat Jul 26 2014, 01:35:26
Same Error (by Ale)
I have the same error, I posted the file math.h if you can figure out the problem .
Fri Feb 6 2015, 17:17:58, download attachment math.h
solved (by Ale)
Ok, i figured it out.
From gitorious download last code, and run nmake Makefile.msvc.
Sat Feb 7 2015, 04:00:23
math.h (by laurent mahe)
I have the same problem with math.h, is it possible to have the dll file or correction to manage this problem
Thanks
Sun Jun 26 2016, 03:58:12
FATAL EROOOOOOR (by Amirhossein Najafi)
Hi
Wasted Time???
Tue Jun 20 2017, 12:37:18, download attachment Untitled.png
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.