SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

Show Degrees of Freedom (by T N)
Is this feature working in the current version (2.1~dce90646)? (I am using the Windows build.) I just draw a simple triangle without any constraints, and "Show Degrees of Freedom" does not highlight any point. I expect that all points will highlighted.

Or how to see the degrees of freedom?
Mon Sep 26 2016, 19:00:58, download attachment triangle.slvs
(no subject) (by whitequark)
Tue Sep 27 2016, 02:26:48
(no subject) (by T N)
Is it expected that a new build containing this fix will be released in near feature?
If not, what repo/branch should I build? There are several repos/branches (solvespace, whitequark, Evil-Spirit, ...). I am a bit confused where to get bug fixes for 2.1.
Wed Sep 28 2016, 17:32:06
(no subject) (by whitequark)
solvespace/solvespace is the primary repository, all the rest are not guaranteed to contain working code.

Both branches 2.x and master are expected to be fully functional at all times; in general using master should be fine.
Wed Sep 28 2016, 17:37:06
(no subject) (by T N)
I have just built the Windows version using Visual Studio from solvespace/solvespace/master (according to the build instructions) and I get:

Stack overflow
solvespace.exe!SolveSpace::`dynamic initializer for 'SS''() Line 10 C++

when starting the app.

Is the code broken or I am doing something wrong?

(AppVeyor artifact from whitequark/solvespace/master starts ok. Only difference what I see is, AppVeyor uses VS12 and I am using VS14 Community.)
Wed Sep 28 2016, 18:49:24
(no subject) (by T N)
I just forked solvespace/solvespace and created a build using AppVeyor. So the problem is not in the solvespace/solvespace repo.
Thu Sep 29 2016, 01:34:17
(no subject) (by T N)
Update: Strange...

I run the built file:

https://ci.appveyor.com/api/bu...elWithDebInfo%2Fsolvespace.exe

First time, it started ok.

Second run, it closes after start.
Thu Sep 29 2016, 01:43:04
(no subject) (by T N)
Next update: Now, it seems to be an issue of solvespace/solvespace/master. solvespace/solvespace/2.x currently starts ok.
Thu Sep 29 2016, 02:01:40
(no subject) (by whitequark)
This is probably related to using VS14. There are some fairly gross initialization hacks, which it might not like.

For now I suggest using the Appveyor build artifact from solvespace/solvespace/master (https://ci.appveyor.com/project/whitequark/solvespace).
Thu Sep 29 2016, 09:36:40
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.