SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

Building solvespace on fedora 2.4 question (by wolfv)
Instructions for building on Debian are on https://github.com/solvespace/solvespace
I am trying to build solvespace on fedora 2.4.
So far I have successfully installed:
$ sudo dnf install libpng-devel
$ sudo dnf install json-c-devel
$ sudo dnf install freetype-devel
$ sudo dnf install fontconfig-devel
$ sudo dnf install gtkmm24-devel
$ sudo dnf install pangomm-devel
$ sudo dnf install libGL-devel
$ sudo dnf install mesa-libGLU-devel
$ sudo dnf install glew-devel
$ sudo dnf install cmake

Then the instructions say,
Before building, check out the necessary submodules:

git submodule update --init extlib/libdxfrw

I don't see how that would "check out" anything, but I try it anyways:
$ git submodule update --init extlib/libdxfrw
fatal: Not a git repository (or any parent up to mount point /home)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).

How to update the git submodule?
libdxfrw is on https://github.com/solvespace/libdxfrw

Thank you.
Sun Jul 24 2016, 14:40:45
(no subject) (by wolfv)
I meant "building solvespace on fedora 24".
Sun Jul 24 2016, 14:45:11
(no subject) (by whitequark)
@wolfv The instructions in README are for a git clone. The source tarballs provided by github lack both the contents of a submodule as well as the exact commit at the time of release, and shouldn't really be used for anything, but I can't turn them off.

Instead, start with `git clone https://github.com/solvespace/solvespace` and then get the 2.1 release using `git checkout v2.1`.
Sun Jul 24 2016, 21:07:17
(no subject) (by wolfv)
Thanks whitequark. I was able to complete the instructions, but can not find solvespace.exe.
This is what I did:

$ git clone https://github.com/solvespace/solvespace
$ cd solvespace
$ git checkout v2.1
$ git submodule update --init extlib/libdxfrw
$ mkdir build
$ cd build
$ cmake ..
$ make
$ sudo make install

Where is the solvespace.exe?
$ find . -name "*.exe"
$
Sun Jul 24 2016, 22:04:36
solved (by wolfv)
SOLVESPACE is running on my PC. Hooray!

Here are the complete command lines to install SOLVESPACE on fedora 24:

$ sudo dnf install libpng-devel json-c-devel freetype-devel fontconfig-devel gtkmm24-devel pangomm-devel libGL-devel mesa-libGLU-devel glew-devel cmake
$ git clone https://github.com/solvespace/solvespace
$ cd solvespace
$ git checkout v2.1
$ git submodule update --init extlib/libdxfrw
$ mkdir build
$ cd build
$ cmake ..
$ make
$ sudo make install

executable is:
/usr/local/bin/solvespace

Thank you for your help whitequark.
Sun Jul 24 2016, 23:31:23
(no subject) (by whitequark)
You can also run it without installing as (from the build directory) ./src/solvespace, in case you don't want to pollute your system.
Mon Jul 25 2016, 00:26:08
(no subject) (by Paul)
That works nice but I have 2 comments. First it's using GTK2 not 3. And second, it worked fine for a few minutes but I got a segfault on exit. I'll definitely be using it more on my Fedora machine now.
Wed Jul 27 2016, 08:14:36
(no subject) (by whitequark)
You can build it with GTK3 by configuring as cmake -DGTK=3. You'll need libgtkmm-3.0-dev.

As for the segfault on exit, that shouldn't happen! Please make a debug build (cmake -DCMAKE_BUILD_TYPE=Debug), run it under gdb (gdb --args src/solvespace, from the build directory), and acquire a backtrace once it crashes (bt, in gdb prompt).
Wed Jul 27 2016, 09:50:23
(no subject) (by whitequark)
Sorry, cmake -DGUI=gtk3.
Wed Jul 27 2016, 09:50:39
Thanks (by Larry Hammer)
These step by step instructions work for Ubuntu 16.04 too.
Was running via wine works that way but with a few annoying little issues.
Also a big thank you to all for this program.
Tue Sep 12 2017, 22:46:14
(no subject) (by Larry Hammer)
made a DEB built against Ubuntu 16.04 64.
Installed on my system it works.
I did not list any dependency requirements.
Tue Sep 12 2017, 23:33:55, download attachment solvespace_12232016-2.3_amd64.deb
opps wrong directory (by Larry Hammer)
I was in the wrong directory when I made the deb.
The deb above is actually ver 2.1.
The DEB attached to this post is ver 2.3
Wed Sep 13 2017, 01:20:20, download attachment solvespace_20162312-2.3_amd64.deb
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.