SOLVESPACE -- parametric 2d/3d CAD

(you are viewing a thread; or go back to list of threads)

GTK port; Debian/Ubuntu packages (by whitequark)
I've implemented a complete GTK port that's as usable (maybe even nicer!) than the Win32 one, and of course does not have the rendering bugs in the FLTK port. See

I also packaged it for Ubuntu >=trusty (also installable on Debian >=jessie) with complete desktop integration:

I'm planning a native OS X port as well.
Sat Mar 21 2015, 00:06:35, download attachment 364.png
(no subject) (by yugami)
very nice
Sat Mar 21 2015, 11:20:15
on fedora (by avh.on1)
Definitely works on Fedora 21. From the cmake errors, it was easy to figure out which dependencies to install. Once dependencies were installed, compiling and installing were quick and easy.

Thanks for the port!
Mon Mar 23 2015, 23:47:46
spaceware library? (by avh.on1)
Just updated the git repo, cmake now gives this error:


This seems to be an old driver for 3Dconnexion input devices. Thinking it was odd that I was able to build only a few days ago on the same system, I poked through CMakeLists.txt. The following modification made my build work:

after this line: else() # Linux and compatible systems
comment out this line: find_package(SpaceWare)
add these lines (copied from Win build settings):

I have access to a 3dconnexion device at work, so I can test later to see if this breaks functionality.

Some poking around on the internet lead to this thread:
It seems that the spaceware driver is quite out of date. It may not be appropriate to include or reference this driver. Looking through the repos, spacenavd provides the driver for these devices now (on debian and fedora systems).
Fri Mar 27 2015, 10:54:25
(no subject) (by whitequark)
This of course would not work, it's impossible to link the Windows-only .lib file on Linux. You need to install it via:

apt-get install libspnav-dev

Either way, this error is not fatal, cmake still configures the build without libspnav.

(I wonder why the build succeeded at all)
Fri Mar 27 2015, 20:53:25
(no subject) (by whitequark)
@avh.on1, turns out I forgot to add libspnav support to GTK port. I've added it. Please build and test the compat branch!
Sat Mar 28 2015, 22:20:29
with libspnav support aded (by avh.on1)
Just compiled, worked fine. Thanks!
Mon Mar 30 2015, 01:29:06
gtk port compiles easily (by John Griessen)
Thanks for that gtk port. What will it take to test it enough to put in main github repo?

John Griessen
Wed Apr 8 2015, 17:56:53
but rendering has a little problem (by John Griessen)
Rendering has a little problem after I do the extrude difference in tutorial 1.

I had grey shaded surfaces before that, then there is grey only inside the extruded mounting holes.
Wed Apr 8 2015, 18:10:14
GTK port on Debian Testing (by Karol Suprynowicz)
When compiled on Debian Testing, FLTK version was unusable due to graphics bugs (not all front faces rendering, hidden line option not working).
GTK version works perfectly and CMake build system is very practical.
Fri Jun 5 2015, 07:24:02
(no subject) (by Jonathan Westhues)
The FLTK version has some problems; I'd recommend the Windows version under WINE over that.

whitequark's GTK version is much better. The head revision of that has some unnecessary file format breakage, and a few other small issues. My intent was to merge that into my repo with those changes and when he considered that done, not sure of current status.
Fri Jun 5 2015, 10:13:15
gtk port (by John Griessen)
I'm using that gtk port to good effect now.

This is SolveSpace version 2.1 Built 14:14:58 Apr 7 2015

merging would be great when ready.
Fri Jun 5 2015, 13:46:05
problems found with a complex design (by John Griessen)
When I added some workplanes and imported flat sketches the design seg faulted when attempting to open, while Jonathan W. could open the same design OK with the windows compilation. I'm going to start redoing some of the steps to find just when it causes a fail.
Tue Jun 9 2015, 10:44:24
problems found with a complex design (by John Griessen)
I redid the steps of adding stepped construction lines, no problem. Added an import, no problem. Added a workplane and no problem. Oriented workplane with constraints, changed to editing in the new workplane and extruded, no problem.

Stretched two of my extrusions --> segfault.
Tue Jun 9 2015, 11:48:12
(no subject) (by Paul)
Is anyone working on a Fedora package for the GTK version? IMHO this is a must have for them.
Wed Jun 10 2015, 21:41:27
(no subject) (by whitequark)
@John Griessen, could you please share the problematic file, so that I could fix this?
Sun Jun 14 2015, 02:29:12
(no subject) (by Jonathan Westhues)
He posted a link in

I confirmed that it worked with the Windows build, but didn't debug further; so I'm not sure if the problem is only under Linux, or if it's always present but just happens not to manifest under Windows.
Sun Jun 14 2015, 03:00:18
please share the problematic file (by John Griessen)
top file is enclosure-mid-mod-inj-slots-ctr2-21.slvs

import files needed to open it are: enclosure-pcb-slots-1.slvs,


Thanks, John Griessen
Sun Jun 14 2015, 09:10:03
and... the non problematic file (by John Griessen)
a file that works OK before addingmore complexity is

Sun Jun 14 2015, 09:12:53
(no subject) (by whitequark)
The -simplifying19 and -ctr2-21 files don't open for me for some reason because they have extra data (version mismatch? not sure). Either way, the -ctr2-35 file indeed crashes, which happens inside ssglLineWidth. I know why this bug happens and will fix it. You can track progress at
Mon Jun 15 2015, 16:59:01
thanks (by John Griessen)
Thanks for this and the initial work to make solvespace easier to use with linux distros.
Tue Jun 16 2015, 21:49:01
(no subject) (by whitequark)
The crash issue has been fixed. The branch is on track to merge.
Sun Jul 5 2015, 03:04:09
(no subject) (by whitequark)
Fri Jul 10 2015, 13:08:47
GTK port working well (by John Griessen)
Tested the gtk port and it works well. Thanks Whitequark and JW.
Sat Aug 8 2015, 17:42:26
breakage re: force nurbs to mesh (by John Griessen)
When I select several groups, or just one of some particular groups,
to have "force nurbs surf to triangle mesh" the gtk port crashes.

I am looking at using wine again. It's not so good. Maybe because I have a 64 bit machine... setting up virtual machines for win7 sucked a ton of time a while back and I don't want to repeat that.

So, please ask for details that will help debug this on debian amd64 machine.
Sun Aug 9 2015, 22:05:08
breakage re: force nurbs to mesh (by John Griessen)

Shows this behavior. opening the file, and then opening the last group and checking force nurbs to mesh gives a seg fault.
Mon Aug 10 2015, 06:59:30
(no subject) (by whitequark)
I will take a look.
Wed Sep 2 2015, 10:35:25
(no subject) (by whitequark)
I've reproduced that with one of my own (simpler) files, will fix it today.
Mon Sep 7 2015, 16:05:39
(no subject) (by whitequark)
This is fixed in the for-upstream branch of
Mon Sep 7 2015, 19:45:32
(no subject) (by whitequark)
In the future, please report the bugs in or, as the forum does not send out email notifications.
Mon Sep 7 2015, 20:09:06
(no subject) (by User1)
Is there "fresh" builds? Need binary for Ubuntu Thrusty i386. Please make it with latest codebase
Sat Sep 19 2015, 07:30:20
(no subject) (by whitequark)
User1, I've updated the Ubuntu PPA. Additionally, I've set continuous integration so that it uploads nightly builds (for OS X >=10.6, Windows >=Vista and Debian x86_64 >=testing) to GitHub releases, e.g.:
Sat Sep 19 2015, 16:09:22
Ubuntu Wily (15.10) uses GCC5 (by Emyr)
Ubuntu has switched to GCC5 so the dependency "libatkmm-1.6-1" cannot be satisfied by the new package "libatkmm-1.6-1v5".
Tue Dec 8 2015, 08:26:37
(no subject) (by User1)
Please, make new binary (solvespace&libslvs) from latest sources with bug fixes for Ubuntu 14.04(x86 & x86_64) on Launchpad!

Thu Dec 17 2015, 11:51:28
How to install the solvespace on mac? (by Amanda)
I am trying to install the solvespace on my mac but it is not working.... I tried to open .dmg .exe and .pdb, but they are not working. What should I do?
Wed Apr 5 2017, 10:58:09
(no subject) (by whitequark)
@Amanda, which version of macOS do you have? How exactly is opening the .dmg not working?
Wed Apr 5 2017, 15:14:25
Post a reply to this comment:
Your Name:
Your Email:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2021 SolveSpace contributors. Most recent update Apr 18 2021.