SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

assembling components says I have problematic edges (by danix)
Hello everyone,
I'm trying to build a tolerance test for my 3d printer. I took inspiration from MakersMuse tolerance test, and I designed the piece in different parts to be assembled before sending it to slice and print.
The problem I'm encountering, is that every single part has no issues, but when I put them together it gives an error regarding the mesh being self intersecting and having problematic edges.
I tried forcing NURBS surfaces to triangle mesh but without success. I've attached a zip with all the files you need to give it a look.

I hope you can help me :) "you're my only hope"
Thanks in advance
Thu May 13 2021, 05:07:14, download attachment tolerance-test.zip
(no subject) (by Andrew)
The problem arises from the text giving the tolerances; it seems like the text capability is buggy. Remove the text and the stl exports fine. You could perhaps look at an alternative way of marking the tolerance, like number of dots (1,2,...) for each tolerance instead of the text.
Thu May 13 2021, 08:21:59
(no subject) (by danix)
thanks a lot for your reply, but even after removing the text, I tried exporting the STL and it still complains about the mesh being self intersecting with a lot of problematic edges. I've attached a picture. Did you do anything else other than removing the text? Force NURBS or anything else really? I'm new to this software, so I'm still learning my way with it..
Thu May 13 2021, 09:34:50, download attachment 2021-05-13-153002_1366x768_scrot.png
(no subject) (by Andrew)
Which version are you using? I am using version 3. Deleting the text group worked fine for me., as did deleting the text and adding some circles to mark the tolerances. The circles work so long as they are not extruded too deep >3 mm, into the outers, and do not cross the outer boundary..

An aside, the 0.1 and 0.2 outers are missing the same orientation constraint to keep the aligned.
Thu May 13 2021, 10:04:02
(no subject) (by danix)
I'm on version 3 as well, solvespace keeps complaining but the exported file was fine in my slicer (cura). At this point I don't understand why, but as long as the file gets exported correctly I have no issues.

Thanks for your help!!
Thu May 13 2021, 10:31:36
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2021 SolveSpace contributors. Most recent update Apr 18 2021.