SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

Error on save : "Couldn't write to file" (by John F.)
On trying to save a file (eg JF.slvs) or export a view etc. I get the error, " Couldn't write to file 'run/user/1000/doc/a0002d9/JF.slvs' " ... although the chosen folder was " /home/john/Documents/SolveSpace Drawings/ "

Any idea why please? SolveSpace was installed on Linux Mint 18.3 using snap and seems to work fine - just won't save since recent updates.
Mon Apr 5 2021, 10:47:41
(no subject) (by Paul)
Not sure if you're a code kind of person. I think this was likely introduced with PR #997 here: https://github.com/solvespace/solvespace/pull/997

I have a new PR that reverts the change, but has not been merged yet. Ideally you could try it out: https://github.com/solvespace/solvespace/pull/1001

Otherwise I will probably merge it and a new edge build should be along later to try.
Mon Apr 5 2021, 11:15:31
(no subject) (by John F.)
Hi Paul,

Not a code kind of person at this level. I just let snap install and update SolveSpace so I'd be waiting on any changes to come that way before I could test it. Please elaborate on, "I will probably merge it and a new edge build should be along later to try". Do you mean you'd have an appimage for example I could download and try or have I misunderstood. John F.
Mon Apr 5 2021, 11:41:44
(no subject) (by Paul)
John, This has triggered a bit of discussion around what may be causing the problem. It's apparently not the change I thought it was.

Does File->SaveAs work for you?

The SNAP build ususally gets updated when we make changes, but none have happned yet.
Mon Apr 5 2021, 13:45:24
(no subject) (by John F.)
Hi Paul,

It seems a bit weird. I opened SolveSpace and was able to use SaveAs to save an old project under a new name and then I tried again and I wasn't and got the " Couldn't write to file ... " error. I think the difference is that if I choose a NEW filename and a file location then it doesn't work - but if I choose to overwrite an existing file then I get the "Exists - Do you want to replace" dialogue and choosing to replace then saves the file OK.

It's evening now where I am and I'll look again tomorrow and try to give a more coherent answer.

Thanks. John F.
Mon Apr 5 2021, 15:31:52
(no subject) (by John F.)
I'm running Linux Mint 18.3 with the XFCE desktop. It's worth mentioning that Linux Mint 18.3 was released on November 27, 2017 and reaches End Of Life this month April, 2021. I plan to upgrade but the latest Mint won't run on this (circa 2007) PC and I am building another with more up to date hardware.

I start SolveSpace from the menu. The menu command is
"env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/solvespace_solvespace.desktop /snap/bin/solvespace"

The "Working Directory" entry is currently blank.

After I start SolveSpace, the top bar shows, "new sketch - SolveSpace". If I use File/Open and navigate through folders to /home/john/Documents/SolveSpace Drawings/First.slvs the file opens but the top bar shows, " /run/user/1000/doc/cf86309a/First.slvs - SolveSpace ".

If I click File/Save the file is saved and updates size and time in the folder /home/john/Documents/SolveSpace Drawings/ (viewed using the File Manager). I can use File/SaveAs to save a copy with a different name and the file is saved and updates in the folder.

If I then start a new file with File/New, the top bar shows, "new sketch - SolveSpace" as before. I draw a square and attempt to save it as Second.slvs in the folder /home/john/Documents/SolveSpace Drawings/. That works OK.

I then attempt to Export 2d View... the file as Second.svg choosing Scalable Vector Graphics (svg) to the same folder and get error " Couldn't write to '/run/user/1000/doc/bf4e06ed/Second.svg "

Now when I try to use File/SaveAs Third.slvs I get the error " Couldn't write to ". If I choose an existing file to overwrite I get the File Exists dialogue and choose Replace and the file saves OK.

Similarly, if I rename a random *.slvs file as MyFile.svg and then attempt to use Export 2d View... by choosing the existing file named Myfile.svg I get the File Exists dialogue and choose Replace and the file saves OK. The resultant svg file opens correctly in Inkscape.

-----

For completeness, I tried setting a Working Directory as " /home/john/Documents/SolveSpace Drawings/ " in the Linux Mint menu item for SolveSpace and closed and re-opened SolveSpace. It didn't seem to make any difference. I wondered if the space in the folder name "SolveSpace Drawings" was the problem but it makes no difference.

In summary, something strange happens for me in the Save File dialogue during use of SolveSpace and appears to happen whether I use File/Save, SaveAs or Export options.

I appreciate your help but want to emphasise I'm only a very casual SolveSpace user, I have found a workaround (always overwrite an existing file) and I am currently using an almost obsolete Operating System which I will soon replace with something newer (probably Linux Mint Linux Mint 20.1 Cinnamon desktop with an EOL April, 2025) so all my problems may just go away.

Thanks again for your interest. I'll keep checking the forum periodically and keep an eye open for changes to Solvespace (currently showing as Help/About/ version 3.0~a01dd184.

John F.
Tue Apr 6 2021, 05:35:45
Issue created on gitHub (by ruevs)
Thanks for the detailed description.

I created an issue on GitHub to track this https://github.com/solvespace/solvespace/issues/1005 .

If you have an account you are welcome to join the discussion there. If not, continue using this thread.
Wed Apr 7 2021, 06:27:43
(no subject) (by John F.)
Hi ruevs, I don't have a GitHub account so I'll keep an eye out on the forum. Solvespace is currently showing as Help/About/ version 3.0~853e7d83 (different from yesterday) but the problem remains. John F.
Wed Apr 7 2021, 10:42:03
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2020 SolveSpace contributors. Most recent update Oct 30 2020.