SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

Constraining errors (by Alex)
Can someone tell me if I'm doing anything wrong or did I find a bunch of bugs? When I try to reorient a part I imported into an assembly I get an error "SOLVE FAILED unsolvable constraints". I tried to orient it to its own reference normal, to another normal and even to a coordinate workplane. I'm using the latest version of the software. And not just this. When I try to put the parts together by constraining point on point, I get the same error. I've attached the assembly. There are 3 parts of the same pipe which should go end to end. And there are more errors that I get. Like when I try to cut a hole by difference extruding, on the workplane that I drew the hole in there's sometimes a thin lid of sorts no matter which way I move the extrude. Sometimes covering the whole hole or sometimes just half of it.
Wed Oct 14 2020, 07:21:37, download attachment example.slvs
(no subject) (by Tom)
Did you do the assemblies tutorial? If you can, it's easiest to drag the part to roughly the right orientation first, then constrain same-orientation on two normals, then coincident on two points.

http://solvespace.com/box.pl
Wed Oct 14 2020, 07:33:26
(no subject) (by Alex)
I see. So the solver cannot reorient the part from just any position to match the new constraint. You have to orient it yourself roughly first and only then can it help you. Ok, one problem solved. Now for the point on point error. I even watched the video tutorial on this. I even tried just now to roughly put them together but still the same error appears. I selected the point at the center of one part then the point at the center of another part then aplied the "on point...." constraint. Poof... red screen.
Wed Oct 14 2020, 07:43:32
(no subject) (by Tom)
Did you constrain orientation first?
Wed Oct 14 2020, 07:47:47
(no subject) (by Alex)
Oh, I tried this first in the same file/session by extruding once then sketch again around the same points then extrude again. Only the plane of contact was all radiating red and the new extrude of two concentric circles was only extruded on 3 quarters of the circle line. It looked like a pipe with a side missing.
Wed Oct 14 2020, 07:50:11
(no subject) (by Alex)
No. I cannot. I only managed to get one part perpendicular to the others. I cannot make any of them to have the same orientation.
Wed Oct 14 2020, 07:52:32
(no subject) (by Tom)
I don't think the program works like you think. Parts don't work like that, has to be one file per part plus a different file for the assembly.
Wed Oct 14 2020, 07:54:24
(no subject) (by Alex)
This is how I made the sketch that I attached to my first post. I made one file for each part, saved them. Then I opened a new file and the chose "New Group > Link/Assemble" and one by one chose the files for each part to import them. Here's a screenshot if it helps.
Wed Oct 14 2020, 07:57:21, download attachment example.png
(no subject) (by Tom)
Did you try dragging each part to about the right orientation, then constraining two normals with same-orientation, then constraining the points coincident? That always works for me. I can't open your file because it's only the assembly file and it needs the parts too.
Wed Oct 14 2020, 08:05:25
(no subject) (by Alex)
Here are the files. Yes. I did try that. I always get the error in the screenshot.
Wed Oct 14 2020, 08:08:39, download attachment gura teava.slvs
(no subject) (by Alex)
Second one
Wed Oct 14 2020, 08:09:06, download attachment gura teava 2.slvs
(no subject) (by Alex)
Third
Wed Oct 14 2020, 08:09:28, download attachment gura teava 3.slvs
(no subject) (by Tom)
I don't see any constraints in your assembly? I tried constraining with same-orientation and then point on point, and it worked for me. Are you sure the two points/normals you're constraining aren't actually both on the same part (vs. on two different parts, or on a part and the original references in the assembly)?
Wed Oct 14 2020, 08:27:54
(no subject) (by Alex)
I am very sure. I even spaced them out to avoid any errors and still it doesn't work.
Wed Oct 14 2020, 08:30:25
(no subject) (by Tom)
Can you post the assembly with the error?
Wed Oct 14 2020, 08:36:42
(no subject) (by Andrew)
When building up an assembly you need to constrain each part as you bring it into the assembly. I.e bring in the first part, place and constrain it in the blank drawing, link the second part and constrain it and place it on the first part, and repeat with the third part. Constraints apply between the current active group and itself or previous groups. If you linked the parts in the order they need to be assembles, just select the groups and set the constraints.
Wed Oct 14 2020, 08:46:44
(no subject) (by Alex)
I did. It is attached to the first post.
Wed Oct 14 2020, 08:47:28
(no subject) (by Tom)
I downloaded the assembly from your first post. It has the parts, but no constraints so no errors.

Like Andrew is saying maybe you're creating the constraints in the wrong group? It has to be in the group for the part you're constraining.
Wed Oct 14 2020, 08:52:11
(no subject) (by Alex)
Andrew, bingo. If I fix the first part in place before I import the second, then everything works. Thank you.

All these quirks tell me SS is a powerful but unfinished software. Think anyone is going to improve it in the future?
Wed Oct 14 2020, 08:53:03
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2020 SolveSpace contributors. Most recent update Oct 30 2020.