SOLVESPACE -- parametric 2d/3d CAD
Examples
Tutorials
Features
Download
Reference
Technology
Library
Forum
Contact
USER FORUM

(you are viewing a thread; or go back to list of threads)

Influence on granularity when drawing an arc or circle (by Jaap)
An arc or circle is 'build' out of several straight line pieces. As a result these line-pieces show up in a 3d-print.
Especially at large diameters this becomes very notable.
Is there a way to instruct solvespace to use smaller pieces?

As an example i include my design of an oil-filter wrench. Although not critical for this work piece, the outer circle became kind of like the inner one...
Sun Jan 11 2015, 15:25:32
attachment (by Jaap)
And then I find that the attachment is missing, here it is
Sun Jan 11 2015, 15:27:38, download attachment Oliefilter-sleutel.slvs
(no subject) (by rune)
You should zoom in before exporting then the rendering becomes smoother. Ive posted a version in this forum where you can set a default zoom e.g. 100. Then you have a consistent level of detail of all your 3D printouts.
Let me know how it works out?
Sun Jan 11 2015, 16:57:59
(no subject) (by Jonathan Westhues)
The chord tolerance depends on your zoom level; so you can zoom in and then choose Edit -> Regenerate All, as noted above. You may wish to show the mesh (second icon from the right) in the browser window, to see what you're about to export.

You can also change that chord tolerance, in the configuration screen; for a finer mesh, decrease "chord tolerance" and/or increase "max piecewise linear segments".

Finally, depending on your CAM software, you may be able to import STEP instead of STL. That represents curves exactly, and will avoid this problem altogether.
Sun Jan 11 2015, 20:13:01
(no subject) (by Rune)
In addition to what Jonathan says, be aware that even if you change the cord tolerance you may get different results of your print depending on your zoom level when exporting, that is why I implemented a fixed zoom in the export routine. I realize now that a better solution would be a have a mm based chord tolerance for exporting.
Btw. Using Slic3r I find that exporting as obj file gives much more reliable results.
Mon Jan 12 2015, 03:40:24
(no subject) (by Jaap)
So i had a little success, but still quite unpredictable what will happen. Now I have another drawing that consists out of an assembly of different parts. I do not understand how to issue the correct actions to change all curved lines to smooth one's.

And this drawing definitely need some improvement!

This is a drawing of a stuart V10 cylinder support I intend to cast using the "lost PLA method". However there are still some curves that do not improve (e.g. the curve in the angle of the mounting-foot).

Changing to OBJ does not show any noticeable improvement to me.

Guess this an issue for improvement if you ever consider an update!

BTW. I am using Repertier host and slic3r for processing, all together I am very happy with this chain of tools.
Sun Jan 25 2015, 14:36:59, download attachment StuarCylinderSupports.slvs
(no subject) (by Jaap)
While I was sending the message above I just realize that I have to do the change in chord/segments for each part apart!

And that helped to get a perfect output!

Awesome program!
Sun Jan 25 2015, 14:51:03
(no subject) (by Rune)
Hi Jaap, just to let you know that there is a branch https://github.com/ThorsenRune/solvespace which sets a fixed export resolution to overcome exactly this problem.

You can set a fixed zoom level when you export to get uniform results.
Attached you see the comparison made with slicer. I had the same problem that every time I exported the model surface became slightly different.

By the way, there are some missing constraint error in the model.
Mon Jan 26 2015, 14:34:04, download attachment Export_Resolution_comparison_slic3r.jpg
(no subject) (by Max)
I came here looking for an answer to this exact problem - curve fidelity depending on zoom at the time of export makes, nicely put, less than zero sense. Unfortunately, the mentioned solution from Github doesn't seem to work either - exporting in .stl format (via "export triangle mesh") seems to export at whatever zoom / resolution I last left the main view, exactly as the original SolveSpace. Is there something special I need to activate for this to work or something?
Tue Jan 27 2015, 05:33:27
(no subject) (by Rune)
Hi Max, I had written a readme file but it has disappeared.
You need to click the new options in browser, check ]Enable GUI revision RT2014]
Below you find a zoom level that you can set to, say 1000.
When you export it will zoom to this level and render the export file, whereafter it returns the previous zoom level. It's a workaround that at least guarantees consistent output details.

Soon I'll upload a new version which does also clipboard export and setting multiple constraints in one go.

Let me know if you like it and I'll clean the code and ask Jonathan if he likes to include the changes.

p.s. If you do Slic3r I find that you get much better results (manifold) exporting as OBJ rather than STL,
Wed Jan 28 2015, 03:09:51
Post a reply to this comment:
Your Name:
Your Email:
Subject:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.