SOLVESPACE -- parametric 2d/3d CAD

(you are viewing a thread; or go back to list of threads)

problems building on ubuntu fresh installation (by GUY)

after doing all that this page says, still have errors and the program will not compile.
is there any one who can finger the problem ?
i tried as root and as a normal user.

i am not a programmer .. and have no idea what i do here.

** i think the build is looking for some GIT files which i dont have. i downloaded the solvespace from the Download page.

[email protected]:~/Downloads/solvespace-2.3/build$ cmake ..
CMake Error at cmake/GetGitCommitHash.cmake:8 (file):
file failed to open for reading (No such file or directory):

Call Stack (most recent call first):
cmake/GetGitCommitHash.cmake:35 (get_git_commit_hash)
CMakeLists.txt:23 (include)

-- Using in-tree libdxfrw
CMake Error at cmake/GetGitCommitHash.cmake:8 (file):
file failed to open for reading (No such file or directory):

Call Stack (most recent call first):
cmake/GetGitCommitHash.cmake:35 (get_git_commit_hash)
extlib/libdxfrw/CMakeLists.txt:23 (include)

-- Using in-tree libdxfrw
CMake Error at extlib/libdxfrw/CMakeLists.txt:99 (add_subdirectory):
add_subdirectory given source "extlib/libdxfrw" which is not an existing

CMake Error at extlib/libdxfrw/CMakeLists.txt:193 (add_subdirectory):
add_subdirectory given source "tools" which is not an existing directory.

CMake Error at extlib/libdxfrw/CMakeLists.txt:194 (add_subdirectory):
add_subdirectory given source "src" which is not an existing directory.

CMake Error at extlib/libdxfrw/CMakeLists.txt:195 (add_subdirectory):
add_subdirectory given source "exposed" which is not an existing directory.

-- Configuring incomplete, errors occurred!
See also "/home/guy/Downloads/solvespace-2.3/build/CMakeFiles/CMakeOutput.log".
[email protected]:~/Downloads/solvespace-2.3/build$

thank you
Wed Mar 22 2017, 14:16:00
(no subject) (by Andrew Bromley)
I had similar problems when I downloaded the sources, rather than using git clone. So try using git to get the sources.
Thu Mar 23 2017, 09:46:59
lions and tigers and Gits, oh my! (by FOSS Advocate)

Hello :)

Brilliant stuff!!! We sooooo need a powerful and accessible CAD tool in the Linux / FOSS ecosystem. Please accept heartfelt thanks and massive respect, and pleeeeeease keep working on this project. ;-P

Only discovered SolveSpace yesterday, following a tip on StackExchange ( specifically ). Somehow it had slipped under my radar after years of unproductive internet searches.

Anyway... back to topic, the (non-) install on Ubuntu.

I too hit this issue. I'm using Linux Mint on older hardware. Mint has Ubuntu roots.

Disappointingly, there was no SolveSpace offered in the GUI Software Manager.

So I tried the usual formula : DOWNLOAD the zip from GitHub, UNPACK, follow the BUILD instructions.

Didn't work. :o(

The error-messages were as-per another forum-post : 'Unable to create a GL context'

(solvespace:21615): glibmm-CRITICAL **:
unhandled exception (type Glib::Error) in signal handler:
domain: gdk-gl-error-quark
code : 0
what : Unable to create a GL context

Hitting the search engine led me to an uncomfortable truth : trapped in poverty, with old Intel hardware, unable to go beyond OpenGL v2, the current version does not support me. :o(

However, a comment elsewhere suggested the older '2.x' branch on GitHub for those unable to run OpenGL-3.

I'm not a coder. I'm unfamiliar with Git and GitHub. I had to do much reading and experimenting.

Probably any GitHub experts can point out what's redundant, but without clear concise documentation ahead of time, I was on my own, practising trial and error, but at least the steps below allowed me to build enough of a working application to be able to follow the first Tutorial (specifically, the reinforced drilled Angle-Bracket, for which, many thanks).

These Bash-Terminal command-line steps are based-on and similar-to what the GitHub-README page says, but it was the branch/version thing that was confusing me. That's why there are lots of spacing and status commands, because I like to see and learn from the output.

$ : mkdir -pvm775 ~/solvespace-github

$ : cd ~/solvespace-github/

$ : git clone --recursive

$ : cd ~/solvespace-github/solvespace/

$ : git --git-dir .git --work-tree . status

$ : echo;echo

$ : git checkout "2.x"

$ : echo;echo

$ : git --git-dir .git --work-tree . status

$ : echo;echo

$ : mkdir -pvm775 ../checkout-tests/solvespace-2.x

$ : git clone --local --shared --recursive . ../checkout-tests/solvespace-2.x/

$ : echo;echo

$ : cd ../checkout-tests/solvespace-2.x

$ : git --git-dir .git --work-tree . status

$ : echo;echo

$ : mkdir -pvm775 build

$ : cd build

$ : cmake ..

$ : make

$ : sudo make install

$ : cd

$ : /usr/local/bin/solvespace > /dev/null 2>&1

I think the --recursive flag is significant, but I believe the crucial bit for me on old OpenGL-2 hardware was the step : git checkout "2.x"

It would be nice if Ubuntu or Linux-Mint pre-packaged it and made it available via the GUI.

And please, a sincere request to the Developers, please please pleeeeease don't abandon the 2.x branch for OpenGL-2 trapped users.


Tue Apr 4 2017, 16:23:35
(no subject) (by whitequark)
I have added source packages to releases. E.g. for 2.3, use
Sun Apr 16 2017, 05:06:45
building on puppylinux xenialpup64 (flavour of ubuntu xenial) (by charlie)
Hi whitequark,
I've got a try building solvespace using the source code from:
root# git clone --recursive

and afterwards doing as given in
root# mkdir build
root# cd build
root# cmake .. -DCMAKE_BUILD_TYPE=Release
root# make

In the make step, I got this error message:
-- Checking for module 'json-c'
-- Found json-c, version 0.11.99
-- Checking for modules 'gtkmm-3.0>=3.16;pangomm-1.4;x11'
CMake Error at /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:367 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:532 (_pkg_check_modules_internal)
CMakeLists.txt:194 (pkg_check_modules)

-- Configuring incomplete, errors occurred!
See also "/tmp/solvespace/build/CMakeFiles/CMakeOutput.log".

Here have libgtkmm-3.0 and libgtkmm-3.0-dev version 3.18, libpangomm-1.4 and libpangomm-1.4-dev installed.

I got the same error messages while building on puppylinux Tahr (a ubuntu trusty flavour).

Thanks for any advice!

Sun May 21 2017, 06:12:52
(no subject) (by patrovite)
On xubuntu I used "git clone" and after I followed exactly the github instructions.
Sun May 21 2017, 12:51:00
build on xubuntu (by charlie)
Hi patrovite,

thanks for your reply !

which xubuntu flavour did you use? yakketi? zesty. or xenial?

best regards
Tue May 23 2017, 00:02:29
build on puppylinux derivative xenialpup64- (SOLVED) (by charlie)

build on puppylinux derivative xenialpup64- (SOLVED)

to meet solvespace and gtkmm-3.1.6 dependencies requirements, it needed to load extra dependencies from ubuntu xenial repo; here are they:


All these allowed to get an error free cmake run; and afterwards a 100% error free make.

HTH ;)
Tue May 23 2017, 04:28:57
(no subject) (by patrovite)
@charlie : I use Voyager Linux 16.04LTS. A very nice and complete xubuntu flavour (
Wed May 24 2017, 06:39:29
(no subject) (by User1)
@charlie, could you provide DEB's?
Sun May 28 2017, 08:23:50
version 2.3 build on puppylinux Tahrpup (ubuntu Trusty derivative) (by charlie6)
just to mention that
solvespace build requires a glibc version later than the one of trusty.
So I could not build solvespace-2.3 from git.
Best regards
Mon May 29 2017, 13:25:33
solvespacexenialpup64-2.3.deb package (by charlie6)
@User1 ... and all
here is the link for download:
user:[email protected]

For downloading, check the box in front of solvespacexenialpup64-2.3.deb archive;
then click on the key with red arrow and "Download" or "TÚlÚcharger" text.

0) this archive is given without warranty nor "after sales support" - I miss time even for answering this forum - sorry therefore.
1)the archive size is given 26MB ... I have packaged the deb archive using dpkg-deb puppylinux binary ... I presume the archive not to have been compressed.
2)ther could be missing deps like one of the following, and maybe all:
libjson-c libgtkmm-3.0 libgtkmm-2.4 libpangomm-1.4 libspnav
depending on your xenial session (I do not know about ubuntu xenial stuffs).
Just launch solvespace from a terminal and read the comments about which dep is missing; then I believe launching apt-get 'the_missing_lib' fixes it.

Best regards
Mon May 29 2017, 14:36:15
I had to make a small change when compiling on Ubuntu 17.04 (by Anton)
sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/
Thu Jun 8 2017, 10:13:27
Puppy L:inux Deb package (by Eric Buijs)
Hi Charlie,

if you're still here. Do you mind if I post your solvespacexenialpup64-2.3.deb package and your comments on the Puppy Linux Discussion Forum. I'm pretty sure it will make some people happy.
Wed Apr 11 2018, 04:38:38
(no subject) (by app4soft)
> comments on the Puppy Linux Discussion Forum

@Eric Buijs, mostly all info (including reference link to this discussion) already exist in related thread[0] on Puppy Linux Forum.

Thu Apr 12 2018, 03:53:28
(no subject) (by Eric Buijs)
@Charlie, I see. Good job.
Thu Apr 12 2018, 09:59:17
Post a reply to this comment:
Your Name:
Your Email:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.