SOLVESPACE -- parametric 2d/3d CAD

(you are viewing a thread; or go back to list of threads)

Cannot hide repeated parts in assembly (by u6006)
Is it a bug? I cannot hide a part and its translates in an assembly. I'm using v2.1 in Mac.
Wed Sep 7 2016, 00:31:45
(no subject) (by whitequark)
Can you provide a testcase?
Wed Sep 7 2016, 03:05:47
(no subject) (by u6006)
Here you go.

A "part" (of cylinder) and its translate group (repeated one) were mounted on a "base" (of plate) in all.slvs.

I can hide the parent part if I make it the last to be active. However, I cannot do it if I want to hide a part and/or its translates in the middle. It doesn't work to check the part's hide checkbox, and there's no this thing in its translate group.

Please see the attached tarball for details.
Wed Sep 7 2016, 15:10:16, download attachment example.tar.gz
(no subject) (by Jonathan Westhues)
Show/hide seem to work as designed, but they work only for the entities, not the solid model.

To hide the surfaces, you'd use "suppress this group's solid model"; except that the translate group doesn't have that, and also doesn't respect that setting in the translated group. So the solution is perhaps to make "translate" respect the translated "suppress solid model", as it does for union vs. difference and stuff.
Wed Sep 7 2016, 23:04:06
(no subject) (by u6006)
It works for me if checking "suppress solid model" hides both this group and its translate group.

To workaround it for now, I import the same part multiple times if I need to hide them later in the assembly.
Thu Sep 8 2016, 00:34:06
(no subject) (by whitequark)
@u6006 this bug was fixed and the fix will be present in the 3.0 and 2.2 releases.
Sun Oct 9 2016, 09:32:12
(no subject) (by u6006)
Mon Oct 10 2016, 14:04:01
Post a reply to this comment:
Your Name:
Your Email:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):
© 2008-2018 SolveSpace contributors. Most recent update Nov 22 2018.